SUSE Rancher Manager: Rancher credentials disclosed to third-party hosts
Summary
The Rancher Manager meta proxy did not consistently remove the caller's Rancher credentials from requests forwarded to third-party cloud provider hosts. A signed-in user's browser session or a non-browser client's Rancher API token can therefore be sent to a host on the proxy's allow-list, for example during ordinary use of cloud provisioning forms. Anyone who can operate or observe that host, including through its logs, can obtain a live credential with the affected user's permissions, which may include administrative access to the Rancher control plane and the managed clusters.
Affected
- SUSE Rancher 2.15.0 to before 2.15.3
- SUSE Rancher 2.14.0 to before 2.14.7
- SUSE Rancher 2.13.0 to before 2.13.11
- SUSE Rancher 2.12.0 to before 2.12.15
- SUSE Rancher 2.11.0 to before 2.11.19
- Note: the CVE record marks the default configuration as unaffected, while the advisory states that default deployments are affected once a user opens a cloud provisioning form. Unknown which view is correct; plan for the advisory.
Fixed in
- Rancher v2.15.3
- Rancher v2.14.7
- Rancher v2.13.11
- Rancher v2.12.15
- Rancher v2.11.19
Workaround
- No complete workaround is available; the advisory states that upgrading is the only full remedy.
- Partial measure: remove unnecessary hosts from the whitelist-domain setting, custom cluster and node driver domains, and custom ProxyEndpoint resources (Rancher 2.14 and later).
- Partial measure: create cloud credentials and machine configurations through the API or kubectl instead of the UI provisioning forms for Amazon EC2, DigitalOcean, Linode and phoenixNAP.
- Partial measure: ensure API clients send Rancher API tokens to the meta proxy only together with the X-API-Auth-Header header.
Exploitation
- CVSS 9.1 (CRITICAL), vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.
- CISA SSVC: exploitation none, automatable yes, technical impact total.
- OffSeq lists the CVE as not known to be exploited.
- No public proof of concept or Metasploit module was found in the research. This does not prove that none exists.
- CISA KEV status: Unknown (not checked).
Our recommendation
- Identify all Rancher instances and their versions.
- Upgrade to v2.15.3, v2.14.7, v2.13.11, v2.12.15 or v2.11.19, depending on the branch in use.
- After upgrading, rotate or delete long-lived Rancher API tokens used against the meta proxy and invalidate existing user sessions.
- Review cloud credentials used through Rancher and rotate them if necessary.
- Restrict network access to the Rancher UI and API, and do not expose Rancher directly to the internet.
- Patch the related CVE-2026-88809 (SSRF via allow-list bypass in the same meta proxy) at the same time.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- GitHub Security Advisory GHSA-x82x-2qj6-5rm2 github.com
- SUSE Rancher security advisories and CVEs ranchermanager.docs.rancher.com
- SUSE Rancher CVE documentation (v2.15) documentation.suse.com
- Rancher extensions: node driver proxying extensions.rancher.io
- OffSeq threat radar entry for CVE-2026-88811 radar.offseq.com
- Rapid7 vulnerability database www.rapid7.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 2 Nov 2026, 18:21.
Original description (NVD)
Missing filtering in the SUSE Rancher Manager meta proxy could cause passed in rancher credentials to be leaked to cloud providers. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11,
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
