ThimPress LearnPress: Missing authorization allows access to restricted data
Summary
LearnPress, a WordPress plugin for creating and selling online courses, contains a missing authorization flaw (CWE-862) in versions up to and including 4.4.11. An unauthenticated remote attacker may be able to access functions or data they should not see, such as other users' information. The CVSS base score is 7.5 with a high impact on confidentiality only; the vulnerable endpoint is not described in the sources, and VulDB rates the issue lower (5.3).
Affected
- LearnPress WordPress plugin (ThimPress) up to and including 4.4.11
Fixed in
- Update to LearnPress 4.4.12 or later (per CNA Patchstack; the vendor changelog entry was not verified)
Workaround
- No vendor workaround known. Updating is the fix.
- If updating is delayed, restrict access to affected LMS pages and REST endpoints at the web server or WAF (general practice, not from a source).
Exploitation
- Not known to be exploited (CISA SSVC: exploitation none).
- Automatable: yes. EPSS 0.32 % (percentile 25).
- No public proof of concept found in the research; not fully verified.
Our recommendation
- Check the installed LearnPress version on all WordPress sites and update to 4.4.12 or later.
- Prioritise internet-facing sites.
- Review logs and user/course data for unexpected access.
- Confirm the fixed version against Patchstack and the vendor before closing the ticket.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Patchstack: WordPress LearnPress <= 4.4.11 Broken Access Control patchstack.com
- CVE Program record (cvelistV5 release) github.com
- OffSeq Radar: CVE-2026-115599 radar.offseq.com
- VulDB entry 428357 vuldb.com
- LearnPress changelog learnpresslms.com
- InstaWP: LearnPress plugin page instawp.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 2 Nov 2026, 11:27.
Original description (NVD)
Missing Authorization vulnerability in ThimPress LearnPress learnpress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects LearnPress: from n/a through 4.4.11.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
