IBM Langflow OSS: Code execution due to improper input validation
Summary
IBM Langflow OSS versions 1.0.0 through 1.12.2 contain a flaw caused by improper input validation (CWE-693). A remote attacker with a valid, low-privilege account can execute arbitrary code. Anonymous access is not sufficient, but code runs with the privileges of the Langflow process, so stored credentials, API keys and connected services are at risk. Technical details of the affected code path are not disclosed.
Affected
- IBM Langflow OSS 1.0.0 through 1.12.2
Fixed in
- Upgrade to 1.12.3 or later. The fix version is taken from the OSV record and the IBM bulletin's recommendation for this product range. Confirm on the IBM bulletin before relying on it.
Workaround
Unknown. No vendor-specific workaround identified for this CVE.
Exploitation
- Not listed in the CISA KEV catalog (per OpenCVE and Strix).
- No exploitation reported for this CVE and no public proof-of-concept found.
- CISA SSVC: not automatable, total technical impact.
- Other Langflow CVEs have been exploited, so the product is actively targeted.
Our recommendation
- Inventory all Langflow OSS instances, including Docker images and desktop installations.
- Upgrade affected versions to 1.12.3 or later after confirming on the IBM bulletin.
- Review user accounts and remove unneeded or shared accounts.
- Restrict network exposure of Langflow, especially internet-facing instances.
- Review logs for unexpected flow changes or executions.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- IBM Security Bulletin: Langflow OSS is affected by multiple vulnerabilities www.ibm.com
- OSV record CVE-2026-97678 osv.dev
- OpenCVE CVE-2026-97678 app.opencve.io
- Strix CVE-2026-97678 www.strix.ai
- DEV Community: Incident response checklist for Langflow OSS 1.0.0 through 1.12.2 dev.to
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 21:28.
Original description (NVD)
IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated attacker to execute arbitrary code due to improper input validation.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
