PressTigers Simple Event Planner: PHP Object Injection via untrusted data
Summary
The WordPress plugin Simple Event Planner by PressTigers up to version 1.5.7 deserializes untrusted data, which allows PHP object injection. An attacker with low privileges on the WordPress site, such as an account with some access, can exploit this flaw to manipulate how the site processes data. Successful exploitation can affect confidentiality, integrity and availability; whether code execution is possible depends on gadget chains present in the site's other code, which is not confirmed.
Affected
- Simple Event Planner WordPress plugin, all versions through 1.5.7
- CVSS 3.1: 8.8 (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)
- CWE-502: Deserialization of Untrusted Data
Fixed in
- Update to version 1.5.8 or later (per Patchstack and the CNA solution; the 1.5.8 changelog lists a fix for PHP object injection in the template, not verified against the code)
Workaround
- No vendor-documented workaround known.
- If the update cannot be applied immediately, deactivate the plugin until it is updated.
Exploitation
- No known exploitation in the wild at the time of research.
- No public proof of concept found.
- CISA SSVC: exploitation none, automatable no, technical impact total.
- Patchstack rates it as medium priority and expects exploitation.
Our recommendation
- Check whether the plugin is installed and which version is active in the WordPress admin dashboard.
- Update to version 1.5.8 or later immediately, or remove the plugin if it is not needed.
- Prioritise internet-facing sites and sites with multiple user accounts.
- Review user accounts and monitor logs for unusual requests to the plugin.
- Verify the update with the vendor or Patchstack, as no PressTigers advisory was found.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Patchstack vulnerability entry CVE-2026-97257 patchstack.com
- VulDB CVE-2026-97257 vuldb.com
- Offseq Radar CVE-2026-97257 radar.offseq.com
- Strix CVE-2026-97257 www.strix.ai
- WordPress.org Simple Event Planner plugin wordpress.org
- PressTigers Simple Event Planner on GitHub github.com
- Qualys October 2026 application security detections notifications.qualys.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 22:30.
Original description (NVD)
Deserialization of Untrusted Data vulnerability in PressTigers Simple Event Planner simple-event-planner allows Object Injection.This issue affects Simple Event Planner: from n/a through 1.5.7.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
