GitLab CE/EE: Remote code execution via CI/CD regular expression
Deadline for US federal agencies: 1 Nov 2026
Summary
Self-managed GitLab CE/EE instances contain an integer overflow in the CI/CD regular expression compiler (CWE-190), tracked as CVE-2026-97229 with a CVSS score of 10.0. Under certain conditions, an unauthenticated attacker can submit a specially crafted regular expression in a CI/CD configuration and execute arbitrary code on the GitLab server. CISA has added the flaw to its Known Exploited Vulnerabilities catalog, and GitLab.com and GitLab Dedicated were already patched by the vendor.
Affected
- GitLab CE/EE 19.2 before 19.2.8
- GitLab CE/EE 19.3 before 19.3.5
- GitLab CE/EE 19.4 before 19.4.2
Fixed in
- GitLab CE/EE 19.2.8
- GitLab CE/EE 19.3.5 (not 19.3.4, which has a merge request page bug with the Ona integration)
- GitLab CE/EE 19.4.2
Use the newest patch release on your branch. Later releases are reported only by secondary sources and must be verified on docs.gitlab.com.
Workaround
No workaround documented by the vendor. Interim measures suggested by a third party: restrict network access to the GitLab web interface to trusted networks or a VPN, and disable public project creation and anonymous access to CI/CD endpoints where feasible. These measures are not verified by the vendor.
Exploitation
- Actively exploited: CISA added CVE-2026-97229 to the KEV catalog on 29 October 2026, with a remediation deadline of 1 November 2026.
- An attempted attack reportedly targeted Alpine Linux's GitLab instance with crafted CI configurations, causing repeated worker crashes.
- Rapid7 reportedly reproduced code execution on an unpatched GitLab CE image 19.4.1, while the patched 19.4.2 image did not respond to the same input.
- No authentication is required. The Alpine case reportedly involved a newly registered account.
Our recommendation
- Inventory all self-managed GitLab instances and their versions.
- Upgrade to the newest patch on your branch, at least 19.2.8, 19.3.5 or 19.4.2, and verify against the vendor advisory before closing the ticket.
- Check whether the Ruby bundled with your GitLab installation is patched, because CISA notes that other products may be affected by the underlying Onigmo issue.
- If an instance is exposed, restrict access and review logs for unusual CI configuration submissions and crashing worker processes.
- If compromise is suspected, rotate CI/CD variables and runner tokens.
- Do not confuse this with CVE-2026-110264, a separate GitLab regular expression vulnerability that this update does not fix.
Public exploits
Links to third-party sites, not checked by us – exploit code can contain malware. Only use it in isolated test environments.
- Proof of concept on GitHub (6 repositories)
AmpedWasTaken/CVE-2026-97229-GitLab-CI-CD-Regex-Compiler-RCE · jburgess-r7/CVE-2026-97229-PoC · gandli/cve-2026-97229-lab · Noshadi-sec/CVE-2026-97229 · murat-levi/gitlab-rce-toolkit - Metasploit module exploit/multi/http/gitlab_cicd_regexp_rce_cve_2026_97229 – GitLab CI/CD RegExp Integer Overflow Remote Code Execution
Research sources
- GitLab Critical Patch Release: 19.4.2, 19.3.5, 19.2.8 docs.gitlab.com
- CISA Known Exploited Vulnerabilities Catalog: CVE-2026-97229 www.cisa.gov
- GitLab work item 630686 gitlab.com
- Help Net Security: GitLab CI/CD regular expression compiler vulnerability www.helpnetsecurity.com
- The Hacker News: Attacker tried to exploit Alpine Linux's GitLab thehackernews.com
- PBX Science: CISA adds GitLab CVSS 10.0 flaw to exploited list pbxscience.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 30 Oct 2026, 13:21.
Original description (NVD)
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Required action (CISA)
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
NVD references (7)
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/630686
- https://hackerone.com/reports/4055749
- https://hackerone.com/reports/4058589
- https://github.com/rapid7/metasploit-framework/pull/22017
- https://www.ruby-lang.org/en/news/2026/10/23/regexp-fixes-for-gitlab-cves/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-97229
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
