IT SBIT Services
Schneeberger
DEEN
CVE tracker

CartFlows: Remote code execution by Contributor-level users

CVE-2026-96837High 8.8

← All vulnerabilities

Summary

CartFlows, a WordPress plugin for funnel building and checkout on WooCommerce, contains a remote code execution vulnerability in versions 3.2.0 and earlier. An authenticated user with the Contributor role or higher can run arbitrary commands on the web server. The CNA rates the issue as high severity (CVSS 8.8), but it requires a valid account on the site.

Affected

  • CartFlows 3.2.0 and earlier (<= 3.2.0)

Fixed in

  • CartFlows 3.2.1 or later

Workaround

Unknown.

Exploitation

  • No evidence of active exploitation found; CISA SSVC lists exploitation as none and automatable as no.
  • No public proof of concept found, which does not rule one out.
  • Patchstack describes the vulnerability as highly dangerous and expects exploitation.

Our recommendation

  • Update CartFlows to version 3.2.1 or later on all production and staging sites.
  • Review accounts with Contributor, Author, or Editor roles, remove unused accounts, and reset passwords where needed.
  • Monitor the Patchstack and Brainstorm Force advisories and the NVD analysis for updates.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 23:07.

Original description (NVD)

Contributor Remote Code Execution (RCE) in CartFlows <= 3.2.0 versions.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.