Books Gallery WordPress plugin: Unauthenticated SQL injection
Summary
The Books Gallery WordPress plugin up to and including version 4.8.3 contains an SQL injection vulnerability (CWE-89) that can be exploited without authentication. An attacker can send crafted requests to read, modify or delete data in the website database, including user accounts and private data. Patchstack rates the issue as high priority with a CVSS score of 9.3 and expects it to be exploited, although no public exploitation has been confirmed.
Affected
- Books Gallery WordPress plugin up to and including 4.8.3
- Default configuration: unaffected (per CNA record)
Fixed in
- Version 4.8.4 is listed as the patched version by Patchstack and the CVE record
- Patchstack and the research notes name 4.8.5 as the latest release; 4.8.5 is recommended
- Note: CVE-2026-108487 (stored XSS) affects versions through 4.8.4, so 4.8.5 is the safer target
Workaround
- Unknown.
- Patchstack states it has issued a mitigation rule that blocks attacks; confirm with the provider whether it covers this vulnerability before relying on it.
Exploitation
- Patchstack classifies the vulnerability as high priority and expects exploitation; attacks may be automated.
- CISA SSVC: exploitation none, automatable yes, technical impact partial.
- No public exploit reports were found in the sources.
Our recommendation
- Update the Books Gallery plugin to version 4.8.5 (at least 4.8.4) immediately.
- Check the installed version in the WordPress admin area and in the plugin directory.
- If an update is not possible at once, ask your hosting provider or web developer about virtual patching or temporarily deactivating the plugin.
- Review database and web server logs for unusual requests and check user accounts for unexpected changes.
- Keep WordPress and all plugins up to date and remove unused plugins.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Patchstack: SQL Injection in WordPress Books Gallery Plugin patchstack.com
- Patchstack: Books Gallery vulnerabilities patchstack.com
- WordPress.org: Books Gallery plugin wordpress.org
- Strix AI: CVE-2026-96822 www.strix.ai
- HOL Guard: CVE-2026-108487 (Books Gallery through 4.8.4) hol.org
- WPScan: Books Gallery plugin wpscan.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 03:50.
Original description (NVD)
Unauthenticated SQL Injection in Books Gallery <= 4.8.3 versions.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
