IT SBIT Services
Schneeberger
DEEN
CVE tracker

Apache Thrift PHP: Uncontrolled recursion leads to denial of service

CVE-2026-96289High 8.2

← All vulnerabilities

Summary

The PHP bindings of Apache Thrift lack a recursion-depth guard. This affects struct readers generated with the option --gen php:inlined and the function TProtocol::skipBinary. An attacker who can reach a Thrift endpoint can send deeply nested data to exhaust resources and disrupt the service. The CVSS rating assumes network access and no authentication, but the attack depends on specific conditions.

Affected

  • Apache Thrift PHP bindings (Composer package apache/thrift) before 0.25.0
  • Distribution packages: Azure Linux 3 lists 0.24.0-1 as the last affected version; Debian lists versions up to 0.24.0-2 as affected

Fixed in

  • Apache Thrift 0.25.0 (released 30 Sep 2026)
  • Fixed Debian or Ubuntu package version: Unknown.

Workaround

  • No vendor-documented workaround is known.
  • If an upgrade is not possible immediately, keep Thrift endpoints off the internet and restrict them to known internal clients.

Exploitation

  • No exploitation in the wild known. The CVE is not in the CISA KEV catalogue.
  • CISA SSVC: Exploitation none, Automatable no.
  • No public proof of concept found in the searches performed.
  • EPSS score: 0.00426.

Our recommendation

  • Check inventory for Apache Thrift and PHP applications that use the generated code.
  • Upgrade the PHP library to Apache Thrift 0.25.0 or later, and verify that distribution packages contain a fixed build.
  • Prioritise any Thrift service that is reachable from the internet.
  • Restrict Thrift endpoints to required internal clients and monitor them for resource exhaustion.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 17:11.

Original description (NVD)

Uncontrolled Recursion vulnerability in Apache Thrift PHP bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

NVD references (2)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.