IT SBIT Services
Schneeberger
DEEN
CVE tracker

Apache Thrift Go bindings: Denial of service via highly compressed data

CVE-2026-94637High 8.2

← All vulnerabilities

Summary

The Go bindings of Apache Thrift do not limit the inflated size of ZLIB-compressed frames processed by THeaderTransport. A remote attacker can send specially crafted, highly compressed data to an affected service, causing resource exhaustion and denial of service. Exploitation depends on the deployment, and the issue does not allow code execution or data disclosure.

Affected

  • Apache Thrift Go bindings (github.com/apache/thrift) before 0.25.0
  • Versions 0.24.0 and earlier are affected; the default configuration is unaffected
  • Distribution packages: affected versions are marked by Azure Linux, Ubuntu and Debian; exact distribution fixed versions are unknown

Fixed in

  • Apache Thrift 0.25.0

Workaround

Unknown. No vendor-documented workaround is known. Limiting the size of compressed input from untrusted clients and capping decompressed sizes in application code are general defensive measures.

Exploitation

  • CISA SSVC assessment: exploitation none, automatable yes, technical impact partial
  • No reports of active exploitation found
  • No public proof-of-concept found
  • EPSS 0.00426 (PT); CISA KEV status not checked

Our recommendation

  • Upgrade Go applications to github.com/apache/thrift v0.25.0 and rebuild them
  • Check software inventories and SBOMs for Thrift versions below 0.25.0, especially internet-facing Go services
  • Check distribution security trackers for fixed package versions
  • Monitor for availability problems in affected services

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 17:17.

Original description (NVD)

Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.

NVD references (2)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.