IT SBIT Services
Schneeberger
DEEN
CVE tracker

Apache APISIX: Resource exhaustion in batch-requests plugin

CVE-2026-94250High 8.2

← All vulnerabilities

Summary

Apache APISIX API gateway versions 1.3.0 through 3.18.0 contain a resource allocation vulnerability in the batch-requests plugin. An unauthenticated attacker can exhaust the memory of a gateway worker (out-of-memory condition) if the plugin is used on a route and the batch endpoint is publicly reachable. The impact is a denial of service for API traffic; code execution is not described.

Affected

  • Apache APISIX 1.3.0 through 3.18.0
  • Practically at risk only where batch-requests is used and the batch endpoint is publicly exposed

Fixed in

  • Upgrade to Apache APISIX 3.19.0 (released 2026-09-28)
  • The 3.18.0 release is not a fix

Workaround

  • Remove or restrict the public route that exposes the batch endpoint
  • If batch requests are not needed, disable the batch-requests plugin and restart Apache APISIX, then test in a non-production environment first
  • No vendor-confirmed workaround found for this CVE

Exploitation

  • No known exploitation in the wild; not in the CISA KEV catalog
  • CISA SSVC: exploitation none, automatable no, technical impact partial
  • No public proof of concept found

Our recommendation

  • Inventory all APISIX instances, check the running version and whether batch-requests is enabled
  • Upgrade instances on 1.3.0 to 3.18.0 to 3.19.0; as an interim step, restrict or remove public batch routes
  • Monitor worker memory and restarts on gateways that expose the batch endpoint
  • Review the 3.19.0 breaking changes before upgrading, as clients sending large batches may be affected

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 17:37.

Original description (NVD)

Allocation of resources without limits or throttling vulnerability in batch-requests plugin in Apache APISIX. An unauthenticated caller can drive a gateway worker into OOM via a route where the batch-requests plugin is used and the batch endpoint is publicly exposed. This issue affects Apache APISIX: from 1.3.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

NVD references (2)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.