IT SBIT Services
Schneeberger
DEEN
CVE tracker

Newsletters WordPress plugin: PHP object injection via untrusted data deserialization

CVE-2026-94075Critical 9.8

← All vulnerabilities

Summary

The Newsletters (newsletters-lite) WordPress plugin up to and including 4.18.1 deserializes untrusted data, which allows PHP object injection (CWE-502). An unauthenticated remote attacker can send crafted input over the network without user interaction, which can let them manipulate how the site processes data and run harmful actions on the server. Any internet-facing WordPress site running an affected version is exposed.

Affected

  • Newsletters (newsletters-lite) WordPress plugin, versions through 4.18.1

Fixed in

  • Version 4.18.2 (according to Patchstack and the vendor changelog)

Workaround

  • Unknown. The only mitigation named in the sources is updating the plugin. If updating is delayed, deactivating the plugin on internet-facing sites until 4.18.2 is installed is a suggestion from the research notes, not from a source.

Exploitation

  • CISA SSVC: exploitation none, automatable yes, technical impact total.
  • Not listed in CISA KEV; no known in-the-wild exploitation found.
  • No public exploit code confirmed.
  • Patchstack expects exploitation based on its own judgement.

Our recommendation

  • Inventory WordPress sites for the Newsletters plugin (newsletters-lite) and check the installed version.
  • Update to version 4.18.2 or later, together with the SQL injection fix in the same release (CVE-2026-111402).
  • Review logs on sites that ran 4.18.1 or earlier.
  • Note that earlier releases also fixed unauthenticated PHP object injections in this plugin; verify that the current version is installed.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 30 Oct 2026, 16:37.

Original description (NVD)

Deserialization of Untrusted Data vulnerability in Tribulant Software Newsletters newsletters-lite allows Object Injection.This issue affects Newsletters: from n/a through 4.18.1.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.