Langflow OSS: Code execution via dependency confusion
Summary
IBM Langflow OSS versions 1.0.0 through 1.12.2 are affected by a dependency confusion flaw, classified as an expected behavior violation (CWE-440). According to the CVE record, a remote attacker can execute arbitrary code, with high impact on confidentiality, integrity and availability. Sources disagree on the CVSS score (9.8 vs. 8.8) and on whether user interaction is required, so the exact attack conditions are not confirmed.
Affected
- IBM Langflow OSS 1.0.0 to 1.12.2
- Scope of the open-source package is taken from IBM and OSV; confirm with IBM if certainty is needed.
Fixed in
- Upgrade to Langflow OSS 1.12.3 or later (IBM recommendation).
Workaround
Unknown. No vendor workaround found.
Exploitation
- CISA SSVC: exploitation none, automatable no.
- Not listed in CISA KEV.
- No public exploit or in-the-wild exploitation found; absence of evidence is not proof.
Our recommendation
- Inventory all Langflow instances, including version, install method and network exposure.
- Upgrade to 1.12.3 or later and rebuild container images.
- Pin and verify dependencies, use hashes where possible, and give private package indexes priority.
- Keep Langflow off the public internet until patched and restrict flow-editing rights.
- Rotate API keys and credentials stored in Langflow.
- Check the CVSS vector in NVD and the IBM bulletin for prioritisation.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- IBM Security Bulletin: Langflow OSS www.ibm.com
- OSV: CVE-2026-93675 osv.dev
- OpenCVE: CVE-2026-93675 app.opencve.io
- VulDB: CVE-2026-93675 vuldb.com
- GBHackers: IBM patches multiple Langflow OSS flaws gbhackers.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 30 Oct 2026, 20:53.
Original description (NVD)
IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote attacker to execute arbitrary code due to an expected dependency confusion.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
