CoCart: Cross-Site Request Forgery enables administrator account creation
Summary
CoCart, a WordPress plugin that provides a REST API for WooCommerce carts, before version 4.9.7 does not limit its REST API authentication filter to its own endpoints. This disables WordPress core's REST nonce protection for all routes. An attacker can use a cross-site request forgery attack to create a new administrator account while a logged-in administrator visits a malicious page.
Affected
- CoCart versions 4.9.0 to before 4.9.7 (lower bound per third-party sources; versions before 4.9.0 unknown)
- WordPress/WooCommerce sites with the plugin installed
Fixed in
- Update to CoCart 4.9.7 or later
Workaround
- No official workaround known. The vendor fix is the update to 4.9.7.
- Until patched, deactivate the plugin if the headless cart is not used (suggestion, not a vendor recommendation).
- Until patched, administrators should avoid browsing untrusted websites while logged into the WordPress admin area.
Exploitation
- No evidence of exploitation in the wild found.
- CISA KEV status: not listed according to a third-party aggregator; not verified directly against the CISA catalogue.
- EPSS score 0.11% according to a third-party aggregator.
- Public proof-of-concept status unverified.
Our recommendation
- Check whether the CoCart plugin is installed on any WordPress/WooCommerce site and which version it runs.
- Update to CoCart 4.9.7 or later.
- Review administrator user lists for unexpected administrator accounts, especially on sites that were unpatched.
- Monitor the WPScan, NVD and CISA KEV pages for changes in exploitation status.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- WPScan: CoCart 4.9.0 – 4.9.6 Administrator Account Creation via REST API Authentication Bypass wpscan.com
- CoCart GitHub releases github.com
- WordPress.org plugin listing: Cart REST API for WooCommerce wordpress.org
- VulDB: CVE-2026-93549 vuldb.com
- Rapid7 via Vulners: CVE-2026-93549 vulners.com
- OffSeq Radar: CVE-2026-93549 radar.offseq.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 22:36.
Original description (NVD)
The CoCart WordPress plugin before 4.9.7 does not scope its REST API authentication filter to its own endpoints, which disables WordPress core's REST nonce protection for every route, allowing an attacker to perform a cross-site request forgery attack that creates a new administrator account using a logged-in administrator's session.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
