IT SBIT Services
Schneeberger
DEEN
CVE tracker

Beaver Builder Page Builder: Unauthenticated arbitrary shortcode execution

CVE-2026-92084Critical 9.1Public exploit

← All vulnerabilities

Summary

Beaver Builder Page Builder for WordPress up to and including 2.11.0.5 does not properly validate a value before it is passed to do_shortcode. An unauthenticated attacker can execute arbitrary WordPress shortcodes. Exploitation requires a Beaver Builder page with a Sidebar module that displays attacker-controllable text, such as Recent Comments, and comment moderation disabled or the attacker's comment approved.

Affected

  • Beaver Builder Page Builder (Lite and Pro) up to and including 2.11.0.5

Fixed in

  • Version 2.11.0.6 (according to third-party sources and the WordPress.org listing; vendor advisory not found)

Workaround

  • No vendor workaround found.
  • Interim measure: remove Sidebar-module widgets that display visitor-supplied text, and keep comment moderation enabled until the update is applied.

Exploitation

  • No in-the-wild exploitation found. CISA KEV listing not confirmed.
  • EPSS: 0.53% according to a third-party tracker.
  • A third-party public proof-of-concept repository exists.
  • CVSS 9.1 (CNA) versus 4.8 (WPScan); the 9.1 score is used as planning baseline.

Our recommendation

  • Identify all WordPress sites running Beaver Builder (Lite or Pro).
  • Update to version 2.11.0.6 or later and verify the installed version.
  • Check Sidebar-module layouts for widgets that display visitor-controlled text.
  • Prioritise internet-facing sites, as no login is required.
  • Monitor logs for unusual shortcode-related requests.

Public exploits

Links to third-party sites, not checked by us – exploit code can contain malware. Only use it in isolated test environments.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 07:35.

Original description (NVD)

The The Beaver Builder Page Builder – Drag and Drop Website Builder plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.11.0.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. Exploitation requires the target site to have a Beaver Builder page containing the Sidebar module populated with a widget that displays attacker-controllable text, such as the core Recent Comments widget, with comment moderation disabled or the attacker's comment approved.

NVD references (7)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.