Apache Thrift: Denial of service in PHP thrift_protocol accelerator
Summary
Apache Thrift PHP bindings before 0.25.0 contain a flaw in the PHP thrift_protocol accelerator that involves zero-byte container elements and missing limits on resource allocation and iteration. A remote attacker who can send crafted data to a PHP service that uses Thrift may be able to exhaust resources and cause a denial of service. The CVSS 4.0 base score is 8.7 (High), with impact limited to availability.
Affected
- Apache Thrift (PHP bindings) before 0.25.0
- Packages listed as pkg:composer/apache/thrift before 0.25.0
Fixed in
- Apache Thrift 0.25.0 (per the vendor mailing list and secondary sources; vendor advisory not yet verified)
- Distribution packages: Unknown. Ubuntu lists the thrift package as "Needs evaluation".
Workaround
- No vendor-documented workaround.
- Restrict network access to the Thrift service until the upgrade is complete.
Exploitation
- CISA SSVC: exploitation none, automatable yes, technical impact total.
- Not listed in CISA KEV. EPSS is low (0.00426).
- No public proof of concept or in-the-wild exploitation found in the research. This is not confirmed absence.
Our recommendation
- Inventory PHP applications and bundled libraries (Composer lock files, Linux packages, vendor applications) for Apache Thrift below 0.25.0.
- Upgrade to Apache Thrift 0.25.0 or later, starting with services reachable from outside the internal network.
- Confirm the fix in the Apache mailing list thread before change approval.
- Restrict network exposure of Thrift endpoints and monitor for unusual resource consumption or service outages.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Apache mailing list thread 1 lists.apache.org
- Apache mailing list thread 2 lists.apache.org
- Ubuntu Security CVE-2026-91137 ubuntu.com
- Vulners CVE-2026-91137 vulners.com
- GitHub issue astruzocyber/CVE #1090 github.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 06:05.
Original description (NVD)
Improper validation of specified quantity in input, Allocation of resources without limits or throttling, Excessive Iteration vulnerability in Apache Thrift PHP bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
