IBM Langflow OSS: Code injection allows remote code execution
Summary
IBM Langflow OSS versions 1.0.0 through 1.12.2 contain a code injection flaw (CWE-94) in code generation. A remote attacker with a valid user account can execute arbitrary code on the host running Langflow, with high impact on confidentiality, integrity and availability (CVSS 8.8). Details of the flaw are not public, and the IBM bulletin does not clearly separate this CVE from the other Langflow CVEs it lists.
Affected
- IBM Langflow OSS 1.0.0 to 1.12.2 (inclusive)
Fixed in
- Upgrade to IBM Langflow OSS 1.12.3 or later (PyPI package langflow).
Workaround
Unknown. No official workaround is published for this CVE.
Exploitation
- Not listed in CISA KEV.
- CISA SSVC: exploitation none, automatable no.
- No public exploit or confirmed exploitation for this CVE.
- Other Langflow CVEs (e.g. CVE-2025-3248) are known to be exploited.
Our recommendation
- Inventory all Langflow instances (pip, Docker, desktop) and their versions.
- Upgrade instances at 1.12.2 or earlier to 1.12.3 or later, after testing in a non-production environment.
- Until patched, remove public internet exposure and limit who can create or edit flows.
- After patching, rotate API keys and credentials stored in Langflow and review logs for unusual flow activity.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- IBM Security Bulletin: Langflow OSS is affected by multiple vulnerabilities www.ibm.com
- OSV: CVE-2026-88962 osv.dev
- Langflow release v1.12.3 github.com
- OpenCVE: CVE-2026-88962 app.opencve.io
- Strix: CVE-2026-88962 www.strix.ai
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 21:32.
Original description (NVD)
IBM Langflow OSS 1.0.0 through 1.12.2 could allow a remote authenticated attacker to execute arbitrary code due to improper control of code generation.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
