IBM Guardium Data Protection: Man-in-the-middle via improper certificate validation
Summary
IBM Guardium Data Protection 12.2.2 does not properly validate certificates. A remote attacker who can intercept or redirect network traffic to or from the appliance can carry out a man-in-the-middle attack. No authentication or user interaction is required, but the attack depends on the attacker being in the network path. The NVD score is 8.1 (High), while IBM rates the flaw at 5.6 (Medium) with low impact.
Affected
- IBM Guardium Data Protection 12.2.2
Fixed in
- Update to IBM Guardium Data Protection 12.2.3 (according to the IBM security bulletin).
Workaround
Unknown.
Exploitation
- CISA SSVC assessment: no exploitation known, not automatable, partial technical impact.
- No public proof of concept found in the sources reviewed.
Our recommendation
- Check whether Guardium Data Protection 12.2.2 is in use and update it to 12.2.3 or later.
- Confirm the fixed version with IBM support if needed.
- Keep Guardium appliances on management or database segments, not reachable from user networks or the internet.
- Restrict which hosts can communicate with the appliance and monitor for certificate warnings.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- IBM Security Bulletin: IBM Guardium Data Protection is affected by multiple vulnerabilities www.ibm.com
- Rapid7 vulnerability database entry for CVE-2026-84032 vulners.com
- Strix CVE overview for CVE-2026-84032 www.strix.ai
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 20:28.
Original description (NVD)
IBM Guardium Data Protection 12.2.2 could allow a remote attacker to conduct a man-in-the-middle attack due to improper certificate validation.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
