IT SBIT Services
Schneeberger
DEEN
CVE tracker

Adobe ColdFusion: Improper input validation leading to code execution

CVE-2026-75995High 8.4

← All vulnerabilities

Summary

Adobe ColdFusion 2025 (up to 2025.0.13) and 2023 (up to 2023.0.25) contain an improper input validation flaw (CWE-20). According to the CVE description, an authenticated attacker with high privileges can execute arbitrary code in the context of the current user, with a changed scope. The CVE description says the vulnerable component is restricted to an administrative network zone by default, and exploitation requires adjacent network access and no user interaction.

Affected

  • Adobe ColdFusion 2025: 0 to 2025.0.13
  • Adobe ColdFusion 2023: 0 to 2023.0.25
  • Platform: All

Fixed in

  • Adobe ColdFusion 2025: Update 14 (2025.0.14)
  • Adobe ColdFusion 2023: Update 26 (2023.0.26)

Workaround

No vendor workaround documented for this CVE. Apply the update.

Restrict access to the ColdFusion Administrator and similar interfaces to trusted administrative networks.

Exploitation

Adobe is not aware of any exploits in the wild for any of the issues addressed in this update. No public proof of concept was found for this CVE. CISA SSVC lists exploitation as none and automatable as no.

Our recommendation

  • Check whether ColdFusion 2025 (up to 2025.0.13) or 2023 (up to 2023.0.25) is in use.
  • Update to 2025.0.14 or 2023.0.26 as a priority, since the bulletin also covers unauthenticated critical issues.
  • Test the update first, as Update 26 contains security changes that may need configuration adjustments.
  • Limit administrative access to trusted networks and monitor for unusual administrative activity.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 12:27.

Original description (NVD)

ColdFusion is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. An attacker with high privileges could exploit this vulnerability to execute arbitrary code. The vulnerable component is restricted to an administrative network zone by default. Exploitation of this issue does not require user interaction. Scope is changed.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.