IT SBIT Services
Schneeberger
DEEN
CVE tracker

Vulnity Security plugin: Authentication bypass to administrator via exposed credentials

CVE-2026-75903High 8.1

← All vulnerabilities

Summary

The Vulnity Security plugin for WordPress up to and including version 1.4.3 stores a delegated-login pairing credential file that is not adequately protected on Nginx-based installations. The generated Nginx snippet protects the wrong directory path. An unauthenticated remote attacker can retrieve the stored credentials, forge signed REST API requests and log in as an administrator, which leads to full compromise of the WordPress site.

Affected

  • Vulnity Security WordPress plugin, versions 0 to 1.4.3
  • Condition: Nginx-based installations

Fixed in

  • Version 1.4.4 (according to the WordPress.org changeset; not independently verified)

Workaround

  • Unknown. No vendor workaround found.
  • Until 1.4.4 is installed: check that the credential and pairing files are not reachable over HTTP and that the Nginx snippet protects the correct directory.
  • Deactivate the plugin if the delegated-login feature is not needed.

Exploitation

  • CISA KEV: not listed (per third-party tracker).
  • Public proof of concept: none found.
  • EPSS: 0.00503 (Vulners).
  • CISA SSVC: exploitation none, automatable no, technical impact total.

Our recommendation

  • Update the Vulnity Security plugin to version 1.4.4 or later on all WordPress sites.
  • If the plugin cannot be updated immediately, deactivate it or restrict access to the credential and pairing files.
  • Review administrator accounts, recent logins and site files for signs of compromise on sites that ran 1.4.3 or earlier while on Nginx.
  • Prioritise internet-facing WordPress sites.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 18:53.

Original description (NVD)

The Vulnity Security plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 1.4.3 This is due to insufficient protection of the delegated-login pairing credential file on Nginx-based installations, where the plugin's generated server configuration snippet guards the wrong directory path. This makes it possible for unauthenticated attackers to retrieve the stored credentials, forge signed REST API requests, and log in as an administrator.

NVD references (3)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.