Sakai Conversations: Stored cross-site scripting in topics and posts
Summary
The Conversations tool in Sakai stores topic, post and comment messages without HTML sanitization, and the frontend renders them unsafely. An authenticated user with access to a site that has Conversations enabled can inject HTML and JavaScript that runs in the browsers of other users who view the affected topic or post. Successful exploitation can allow actions on behalf of victims and theft of data visible to them.
Affected
- Sakai 23.0 up to but not including 23.5
- Sakai 25.0 up to but not including 25.3
Fixed in
- Sakai 23.5
- Sakai 25.3
- Sakai 26.0
Workaround
- Unknown. The vendor advisory was not confirmed for workarounds; if patching is not possible, disabling the Conversations tool on affected sites is a possible mitigation.
Exploitation
- Requires a valid account with access to a site that has the Conversations tool enabled, plus a victim who views the injected content.
- CISA SSVC: exploitation status PoC, not automatable.
- No confirmed exploitation in the wild found. Not in KEV catalog.
Our recommendation
- Check whether any Sakai instance is in use and identify its exact version.
- Upgrade to 23.5, 25.3 or 26.0, or disable the Conversations tool until the upgrade is done.
- Review who has accounts and site access, as the attack requires only a standard authenticated user.
- Monitor for suspicious content in Conversations topics and posts.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- GitHub Security Advisory GHSA-w2x5-gv52-9ccv github.com
- Fix commit 2696b4b (SAK-52622) github.com
- OSV: CVE-2026-54049 osv.dev
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 06:17.
Original description (NVD)
Sakai is a Collaboration and Learning Environment (CLE). From versions 23.0 to before 23.5, and versions 25.0 to before 25.3, the Sakai Conversations tool stores topic and post messages without HTML sanitization, and the frontend renders them using LitElement's unsafeHTML() directive, resulting in stored cross-site scripting (XSS). Any authenticated user with access to a site that has the Conversations tool enabled can inject arbitrary HTML and JavaScript that executes in the browsers of all other users who view that topic or post. This issue has been patched in versions 23.5, 25.3, and 26.0.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
