IT SBIT Services
Schneeberger
DEEN
CVE tracker

OpenEMR: SQL injection in Syndromic Surveillance module allows admin takeover

CVE-2026-49142High 8.7

← All vulnerabilities

Summary

OpenEMR before 8.5.0 contains an authenticated SQL injection in the Syndromic Surveillance module, reachable via the form_icd_codes[] parameter. An attacker with a Clinician-level account can read and modify database contents, including bcrypt password hashes, and reset passwords, which can lead to full administrative account takeover. Exploitation requires a valid clinician account; the vendor has fixed the issue in version 8.5.0.

Affected

  • OpenEMR versions before 8.5.0 (VulnCheck CNA data)
  • VulDB states up to 8.4.x; behaviour of older maintained branches: Unknown.

Fixed in

  • OpenEMR 8.5.0 (GitHub release tag v8_5_0; release date listed as 2026-10-26 or 2026-10-27 in different sources)

Workaround

  • No vendor-published workaround. Upgrading to 8.5.0 is the recommended fix.
  • Until patched, restrict access to the Syndromic Surveillance module, for example at the web server or reverse proxy to trusted hosts.

Exploitation

  • Authentication with Clinician-level privileges required.
  • No public exploit code confirmed as of the sources retrieved.
  • Not listed in CISA KEV according to one aggregator (not verified directly).
  • No confirmed in-the-wild exploitation.

Our recommendation

  • Upgrade OpenEMR to version 8.5.0 or later as a priority.
  • Review clinician and other user accounts, and disable unused ones.
  • Check whether the OpenEMR web interface is reachable from the internet.
  • Check the instance for unusual password resets or account changes.
  • Monitor logs for unusual requests to the syndromicsurveillance endpoint.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 23:42.

Original description (NVD)

OpenEMR before 8.5.0 contains an authenticated SQL injection vulnerability in the Syndromic Surveillance module that allows users with Clinician-level privileges to read and modify arbitrary database contents by submitting crafted values in the form_icd_codes[] POST parameter to the syndromicsurveillance/index endpoint. Attackers can inject an unquoted numeric IN() clause and UNION DISTINCT SELECT statement using hex-encoded literals to abuse MySQL extractvalue() for error-based exfiltration of bcrypt password hashes and execute stacked queries that reset passwords, resulting in full administrative account takeover.

NVD references (5)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.