Advantech ADAM-3600 EdgeLink: Stack-based buffer overflow enables code execution
Summary
Advantech ADAM-3600 EdgeLink remote terminal units contain a stack-based buffer overflow (CWE-121). A remote attacker with valid credentials can trigger it to execute arbitrary code on the device. The CVSS 4.0 base score is 8.6 (High), and the attack requires a valid login but no user interaction.
Affected
- Advantech ADAM-3600 EdgeLink prior to version 2.8.5.0
- Default configuration: unaffected (per CNA record)
Fixed in
- Version 2.8.5.0 (named by CSA and Advantech). Verify the firmware image status on Advantech's download page before rollout.
Workaround
- No workaround documented by the vendor.
- Restrict network access to the device (own recommendation, not vendor guidance).
Exploitation
- No known exploitation in the wild and no public proof of concept.
- CISA SSVC: Exploitation none, Automatable no.
Our recommendation
- Identify all ADAM-3600 / EdgeLink devices and their firmware versions.
- Remove direct internet exposure and limit management access to known engineering hosts.
- Update to version 2.8.5.0 as part of the full advisory update, after testing in a staging environment.
- If a device was exposed before the update, check it for signs of compromise.
- Check for default or shared credentials, because a related CVE (CVE-2026-43854) exposes administrator credentials.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- CSA Singapore alert AL-2026-149 www.csa.gov.sg
- Advantech security advisories www.advantech.com
- Advantech ADAM-3600 advisory PDF advcloudfiles.advantech.com
- OpenCVE record CVE-2026-43858 app.opencve.io
- VulDB entry 422738 vuldb.com
- Third-party analysis (Safeguard) safeguard.sh
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 07:41.
Original description (NVD)
A stack-based buffer overflow vulnerability could allow a remote authenticated attacker to achieve arbitrary code execution.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
