IBM DataPower Gateway: Cross-site scripting in Web UI
Summary
IBM DataPower Gateway versions 10.6.0.0 through 10.6.0.10 contain a cross-site scripting flaw in the Web UI. An unauthenticated attacker can embed arbitrary JavaScript, which may alter the intended functionality of the interface and potentially lead to credentials disclosure within a trusted administrative session. IBM rates the issue CVSS 9.3 (Critical); the user interaction component (UI:R) means a victim must act, for example by opening a crafted link.
Affected
- IBM DataPower Gateway 10.6.0.0 through 10.6.0.10
Fixed in
- Upgrade to IBM DataPower Gateway 10.6.0.11 or later
Workaround
- No official workaround documented by IBM.
- Third-party advice: place the DataPower Gateway in a segmented VLAN to limit lateral movement (not vendor-validated).
Exploitation
- No known exploitation found at time of research.
- Not listed in CISA KEV at time of research.
- No public proof of concept found.
- CISA SSVC assessment: Exploitation none, Automatable no, Technical Impact total.
Our recommendation
- Upgrade to 10.6.0.11 as soon as possible, as IBM strongly advises.
- Check whether any DataPower Web UI is reachable from the internet and restrict it to management networks or a VPN until the upgrade is done.
- Review administrator sessions and monitor for unexpected Web UI behaviour.
- Check whether 10.6.0.x is in use; other branches are covered by separate advisories.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- IBM Security Bulletin CVE-2026-14990 www.ibm.com
- IBM Security Bulletin (full advisory) www.ibm.com
- VulDB entry 415399 vuldb.com
- Strix CVE record www.strix.ai
- SecurityOnline advisory overview securityonline.info
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 03:01.
Original description (NVD)
IBM DataPower Gateway 10.6.0.0 through 10.6.0.10 is vulnerable to cross-site scripting. This vulnerability allows an unauthenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
