IT SBIT Services
Schneeberger
DEEN
CVE tracker

IBM DataPower Gateway: Heap-based buffer overflow enables denial of service

CVE-2026-14496High 8.2

← All vulnerabilities

Summary

IBM DataPower Gateway versions 10.5.0.0 to 10.5.0.22, 10.6.1 to 10.6.6, 10.6.0.0 to 10.6.0.10 and 11.0.0.0 to 11.0.0.2 contain a heap-based buffer overflow. A remote, unauthenticated attacker can exploit it without user interaction to crash or disrupt the gateway service. The CVE record describes denial of service only, and no code execution is claimed. NVD and the CNA rate it 8.2, while IBM rates it 7.5 with no confidentiality impact.

Affected

  • IBM DataPower Gateway 10.5.0.0 through 10.5.0.22
  • IBM DataPower Gateway 10.6.1 through 10.6.6 (10.6CD)
  • IBM DataPower Gateway 10.6.0.0 through 10.6.0.10
  • IBM DataPower Gateway 11.0.0.0 through 11.0.0.2

Fixed in

  • 10.5.0.x: upgrade to 10.5.0.23
  • 10.6.0.x: upgrade to 10.6.0.11
  • 10.6CD (10.6.1 to 10.6.6): upgrade to 11.0.0.3 (release-line change)
  • 11.0.0.x: upgrade to 11.0.0.3

Workaround

Unknown.

Exploitation

  • No known exploitation in the wild; not listed in CISA KEV.
  • CISA SSVC: exploitation none, automatable yes, technical impact partial.
  • No public proof of concept found; EPSS about 0.3%.

Our recommendation

  • Check whether DataPower instances exist and which version line they run.
  • Plan the upgrade to the fixed version for each line; for 10.6CD, check the migration path to 11.0.0.3 and compatibility first.
  • Until patched, restrict access to gateway listeners to trusted networks where the design allows.
  • Monitor for unexpected restarts or crashes, which may indicate denial-of-service attempts.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 16:52.

Original description (NVD)

IBM DataPower Gateway 10.5.0.0 through 10.5.0.22, 10.6.1 through 10.6.6, 10.6.0.0 through 10.6.0.10, and 11.0.0.0 through 11.0.0.2 could allow a remote attacker to cause a denial of service due to a heap-based buffer overflow.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.