IT SBIT Services
Schneeberger
DEEN
CVE tracker

vLLM: Denial of service via decompression-bomb image in Nemotron-VL processor

CVE-2026-116177High 8.7

← All vulnerabilities

Summary

vLLM, an inference engine for large language models, disables Pillow's decompression-bomb protection for the whole process when the Nemotron-VL processors are imported. An unauthenticated attacker who can reach /v1/chat/completions can submit a crafted image that exhausts memory and OOM-kills the worker, denying service to other tenants. The risk applies to deployments that serve or import Nemotron-VL processors and expose the API.

Affected

  • vLLM 0.10.2 to before 0.25.0 (CVE record and VulnCheck)
  • The GHSA page lists affected versions as <= 0.8.5; until this is confirmed, treat all versions before 0.25.0 as affected
  • Red Hat AI Inference Server is listed as affected; fixed version unknown

Fixed in

  • vLLM 0.25.0 and later (the latest release is recommended)
  • Backports to older release lines: Unknown.

Workaround

  • Unknown from vendor sources.
  • Restrict network access to the API endpoint until patched.
  • Do not serve Nemotron-VL models until the instance is upgraded.

Exploitation

  • CISA SSVC: exploitation none, automatable yes.
  • Not in CISA KEV; no exploitation reported as of 25 Oct 2026.
  • No public proof of concept found; this is not confirmation that none exists.

Our recommendation

  • Inventory all vLLM instances, including container images and Red Hat AI Inference Server.
  • Upgrade to vLLM 0.25.0 or later, preferably the latest release.
  • Check whether Nemotron-VL models are served, and restrict API access until patched.
  • Monitor for worker crashes and memory exhaustion in AI services.
  • Read GHSA-mm38-5g96-7j6x directly to confirm the affected range.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 00:17.

Original description (NVD)

vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to exhaust memory because the Nemotron-VL processors globally set Image.MAX_IMAGE_PIXELS to None. Attackers can submit a pathological decompression-bomb image to /v1/chat/completions to OOM-kill the worker and deny service to co-tenants.

NVD references (2)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.