Velneo vServer: Denial of service via malformed VATP packet
Summary
Velneo vServer, the application server of the Velneo platform, contains an improper array index validation flaw. A remote attacker can send a malformed VATP packet to crash or hang the service, causing denial of service. According to the CNA record no privileges or user interaction are required, but whether the flaw is reachable before login is not confirmed by the vendor advisory.
Affected
- vServer 36.0 before 36.6
- vServer 37.0 before 37.2
Fixed in
- vServer 36.6
- vServer 37.2
Workaround
- No vendor-documented workaround.
- Restrict network access to the vServer port, keep it off the public internet until patched.
Exploitation
- CISA SSVC: exploitation none, automatable yes, technical impact partial.
- No public proof of concept found; not listed as known exploited at time of research.
- EPSS 0.00344 (low).
Our recommendation
- Inventory all vServer instances, versions and whether they are on-premises or Velneo Cloud.
- Upgrade to 36.6 or 37.2 or a later release on the same branch, after checking the vendor advisory.
- Until patched, restrict access to the vServer port.
- Also address CVE-2026-114462 (symlink-based file read) with the same upgrade.
- Monitor for public proof of concept or KEV listing and recheck NVD once analysis is complete.
- Note: NVD status is Deferred; CVSS 4.0 score is 8.7 in the CNA record, VulDB lists 6.3 (CVSS 3.x).
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Velneo security advisories velneo.es
- Vulners CVE record CVE-2026-114405 vulners.com
- VulDB CVE-2026-114405 vuldb.com
- OpenCVE CVE-2026-114405 app.opencve.io
- HOL Guard CVE-2026-114405 hol.org
- Strix CVE-2026-114405 www.strix.ai
- Velneo vServer documentation doc.velneo.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 01:02.
Original description (NVD)
Improper validation of array index vulnerability in Velneo vServer. This issue affects vServer: from 36.0 before 36.6 and from 37.0 before 37.2.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
