Google Chrome: Improper input validation in Permissions allows sandbox escape
Summary
Google Chrome versions before 156.0.8078.47 contain an improper input validation flaw in the Permissions component. A remote attacker can use a crafted HTML page to potentially execute arbitrary code outside the browser sandbox. The attack requires that a user visits the malicious page; no account is needed. Chromium rates the issue Medium, while NVD and Microsoft score it CVSS 9.6 (Critical).
Affected
- Google Chrome (desktop) before 156.0.8078.47
- Android builds before 156.0.8078.47 (reported as affected by secondary sources)
- Chromium-based browsers that ship the affected Chromium code (e.g. Microsoft Edge), until they include the fix
Fixed in
- Google Chrome 156.0.8078.47 or later (Linux and Android)
- Google Chrome 156.0.8078.47 or 156.0.8078.48 or later (Windows and macOS; sources differ, so use the newest stable build)
- Microsoft Edge: no verified fixed build number found
- Ubuntu: chromium-browser packages are marked as not affected because Chromium is delivered as a snap; the snap must be refreshed
Workaround
- None found. The vendor only recommends updating.
- Restart the browser after the update, because the old process may still be running.
Exploitation
- No evidence of exploitation in the wild found at the time of research.
- Not listed in CISA KEV as far as known; the CISA catalogue was not checked directly.
- No public proof of concept found; this does not rule one out.
- CISA SSVC: exploitation none, automatable no, technical impact total.
Our recommendation
- Check the Chrome version on all endpoints, including Edge and Ubuntu/snap installations.
- Update Windows and macOS hosts to the newest 156.0.8078.x build and Linux hosts to at least 156.0.8078.47.
- Require a browser restart on machines with a pending update.
- Prioritise internet-facing user workstations despite the Medium Chromium rating.
- Recheck NVD, CISA KEV and the Chrome advisory in a few days for changes in exploitation status.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Chrome Releases: Stable Channel Update for Desktop chromereleases.googleblog.com
- Chromium issue 518099505 issues.chromium.org
- Microsoft MSRC: CVE-2026-113084 msrc.microsoft.com
- Ubuntu CVE tracker: CVE-2026-113084 ubuntu.com
- Vulners: CVELIST CVE-2026-113084 (Debian DSA/DLA references) vulners.com
- Cybersecurity News: Chrome security update fixing 353 flaws cybersecuritynews.com
- Penligent: Chrome 156 security update www.penligent.ai
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 30 Oct 2026, 22:35.
Original description (NVD)
Improper input validation in Permissions in Google Chrome prior to 156.0.8078.47 allowed a remote attacker to potentially execute arbitrary code outside the sandbox via a crafted HTML page. (Chromium security severity: Medium)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
