IT SBIT Services
Schneeberger
DEEN
CVE tracker

BuddyPress: SQL injection in WordPress plugin

CVE-2026-111850High 8.5

← All vulnerabilities

Summary

The BuddyPress plugin for WordPress up to and including version 14.5.2 contains an SQL injection vulnerability (CWE-89). An attacker with a logged-in low-privilege account, such as a Subscriber, can send crafted requests to read, modify or delete database content, including user accounts and private data. Patchstack rates the issue as high priority and expects exploitation attempts.

Affected

  • BuddyPress from n/a through 14.5.2 (WordPress plugin)

Fixed in

  • Update to BuddyPress 14.5.3 or later (per the CNA record and Patchstack).

Workaround

  • No vendor workaround known.
  • Patchstack has issued a mitigation rule that blocks attacks until the plugin is updated.
  • Until the update is applied, consider restricting open user registration and reviewing Subscriber accounts (interim measure, not confirmed by the vendor).

Exploitation

  • Not known to be exploited.
  • Not listed in CISA KEV.
  • CISA SSVC: exploitation none, automatable no, technical impact partial.
  • EPSS: 0.21 % (percentile 11).

Our recommendation

  • Inventory all WordPress sites and check whether BuddyPress 14.5.2 or lower is installed.
  • Update BuddyPress to 14.5.3 or later on all affected sites.
  • Until then, restrict open registration and review low-privilege accounts.
  • Check logs for unusual database errors or unexpected queries.
  • Verify the overlap with CVE-2026-115965 before closing this item.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 09:55.

Original description (NVD)

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in BuddyPress BuddyPress buddypress allows SQL Injection.This issue affects BuddyPress: from n/a through 14.5.2.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.