IT SBIT Services
Schneeberger
DEEN
CVE tracker

MailOptin WordPress plugin: Unauthenticated privilege escalation via form mappings

CVE-2026-109515Critical 9.8

← All vulnerabilities

Summary

The MailOptin plugin for WordPress up to and including 1.2.78.6 accepts attacker-supplied field mappings in the subscribe_to_email_list endpoint without validating destination keys. An unauthenticated attacker can use this to overwrite the password of any existing account, including administrator accounts, by supplying the target user ID and a pre-hashed password. Exploitation requires a public WordPress User Registration opt-in form on the site, whose UUID is visible in the page source. The CNA rates the issue CVSS 9.8 (Critical).

Affected

  • MailOptin plugin for WordPress, all versions up to and including 1.2.78.6
  • Vendor per CVE record: properfraction

Fixed in

  • Version 1.2.78.7 (WordPress.org changelog: fixed unsanitized field mapping parameter)

Workaround

  • Disable public user registration forms of the plugin if possible
  • Deactivate the plugin until the update is applied
  • Server-side WAF rules for suspicious form_custom_field_mappings values (stopgap only)

Exploitation

  • Unauthenticated exploitation is possible if a User Registration opt-in form is published
  • A VulnCheck KEV entry exists, but it is unconfirmed; no other source confirms active attacks
  • No public proof of concept found
  • CISA SSVC: automatable yes, technical impact total

Our recommendation

  • Check whether MailOptin is installed on any site and which version is running
  • Update to version 1.2.78.7 or later now
  • If an update is not possible, deactivate the plugin or its public registration forms
  • Review user accounts for unexpected administrators and recent password changes; check the wp_users table
  • Monitor the KEV status and any public exploit

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 30 Oct 2026, 17:44.

Original description (NVD)

The MailOptin – Popup, Optin Forms & Email Newsletters for Mailchimp, HubSpot, AWeber Etc. plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.2.78.6 This is due to the `subscribe_to_email_list` endpoint accepting an attacker-supplied `optin_data[form_custom_field_mappings]` parameter without any allow-list validation on destination keys, allowing the attacker-controlled mapping to override the administrator's saved mapping and pass arbitrary `wp_users` column names — including `ID` and `user_pass` — directly into `wp_insert_user()` via the `subscribe()` function. This makes it possible for unauthenticated attackers to force `wp_insert_user()` into UPDATE mode on any existing account by supplying a target user's numeric `ID`, overwrite that account's password with a pre-hashed value of their choosing, and thereby take over any WordPress user account — including administrators — leading to full site compromise. Exploitation requires that a WordPress User Registration opt-in form is published somewhere on the site, though the form's UUID is visible in page source and no authentication, nonce, or capability check is required to reach the vulnerable endpoint.

NVD references (6)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.