IT SBIT Services
Schneeberger
DEEN
CVE tracker

Nginx UI: Cross-site request forgery in API authentication

CVE-2026-107809High 8.8

← All vulnerabilities

Summary

Nginx UI versions 2.0.0 up to 2.5.0 accept the browser-stored token cookie as an API credential. Because management endpoints do not consistently enforce CSRF tokens or Origin/Referer checks, a remote attacker can make a logged-in administrator's browser send state-changing requests. The attacker can modify Nginx configurations and trigger reloads, but cannot read the responses. Exploitation requires an administrator to visit an attacker-controlled page while logged in, and the account lacks OTP/Passkey or the target endpoint does not require secure-session proof.

Affected

  • Nginx UI (0xJacky) from 2.0.0 up to, but not including, 2.5.0

Fixed in

  • Fixed in version 2.5.0

Workaround

Unknown.

Exploitation

  • No exploitation in the wild known.
  • CISA KEV: not listed.
  • CISA SSVC: exploitation none, automatable no, technical impact total.
  • No public proof of concept found; this does not prove none exists.

Our recommendation

  • Inventory Nginx UI instances and check the version.
  • Upgrade to Nginx UI 2.5.0 or later.
  • Enable OTP/Passkey on all administrator accounts.
  • Restrict access to the administration interface to management networks (VPN or IP allowlist).
  • Instruct administrators not to browse untrusted websites while logged in to Nginx UI.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 20:53.

Original description (NVD)

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, AuthRequired accepts a browser-managed token cookie as an API credential after the front end stores the JWT in that cookie. Because management endpoints do not universally require a CSRF token or perform Origin or Referer validation, a remote attacker can induce a logged-in administrator's browser to submit authenticated cross-site state-changing requests, including POST /api/configs. The attack requires an administrator account without OTP/Passkey or a target endpoint that does not require secure-session proof. The attacker cannot read the cross-origin response but can modify Nginx configuration, trigger reloads, or invoke other management operations reachable with the victim's session. This issue is fixed in version 2.5.0.

NVD references (3)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.