IT SBIT Services
Schneeberger
DEEN
CVE tracker

Ultimate Multisite WordPress plugin: Unauthenticated local file inclusion

CVE-2026-107508High 8.6

← All vulnerabilities

Summary

The Ultimate Multisite WordPress plugin before version 2.17.2 does not validate a user-supplied value used to select a file to include. An unauthenticated attacker can include and read arbitrary local files, including the WordPress configuration file wp-config.php. The issue only matters on WordPress Multisite installations that run this plugin and are reachable from the internet, and reading the configuration file can expose database credentials.

Affected

  • Ultimate Multisite WordPress plugin, all versions before 2.17.2

Fixed in

  • Version 2.17.2 (released 2026-10-06 according to the changelog)
  • Requirements: WordPress 5.3+ and PHP 8.2+

Workaround

  • No workaround is documented in the sources.
  • Until patched, restrict or disable the plugin on any Multisite network.

Exploitation

  • Not listed in CISA KEV at the time of the sources (third-party tracker; please confirm on cisa.gov).
  • CISA SSVC: exploitation none, automatable yes, technical impact partial.
  • EPSS reported between 0.20% and 0.503% by different aggregators.
  • Public proof of concept: unknown.
  • No confirmed in-the-wild exploitation found.

Our recommendation

  • Check whether any WordPress site runs Ultimate Multisite and identify its version.
  • Update to version 2.17.2 or later and confirm the current release on the vendor's GitHub page.
  • If an instance was exposed before patching, review access logs and rotate database and secret credentials.
  • Verify the CVSS vector and NVD status, as NVD analysis is pending.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 08:14.

Original description (NVD)

The Ultimate Multisite WordPress plugin before 2.17.2 does not validate a user-supplied value used to select a file to include, allowing unauthenticated attackers to include and read arbitrary local files, including the WordPress configuration file.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.