IT SBIT Services
Schneeberger
DEEN
CVE tracker

Adobe ColdFusion: Incorrect authorization allows arbitrary code execution

CVE-2026-106090High 8.8

← All vulnerabilities

Summary

Adobe ColdFusion 2025 (up to 2025.0.13) and ColdFusion 2023 (up to 2023.0.25) contain an incorrect authorization flaw. An attacker with a low-privileged local account can execute arbitrary code in the context of the ColdFusion service, with a changed scope and without user interaction. Adobe is not aware of exploits in the wild, but ColdFusion flaws have been exploited quickly after public details emerged in 2026.

Affected

  • Adobe ColdFusion 2025: 0 to 2025.0.13
  • Adobe ColdFusion 2023: 0 to 2023.0.25

Fixed in

  • Adobe ColdFusion 2025: update to 2025.0.14 (Update 14)
  • Adobe ColdFusion 2023: update to 2023.0.26 (Update 26)

Workaround

Unknown. No vendor workaround identified; apply the update.

Exploitation

  • Adobe is not aware of exploits in the wild for the issues in bulletin APSB26-144.
  • No public proof of concept found for this CVE.
  • Not known to be listed in the CISA KEV catalogue (not verified directly).

Our recommendation

  • Update ColdFusion 2025 to 2025.0.14 or ColdFusion 2023 to 2023.0.26 as a priority, then test the applications.
  • Review accounts with local logon rights on ColdFusion servers and limit local and administrator access.
  • Check the full CVE list of bulletin APSB26-144, as the same update covers many other CVEs.
  • Monitor the ColdFusion servers for unexpected processes started by the ColdFusion service.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 17:11.

Original description (NVD)

ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation of this issue does not require user interaction. Scope is changed.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.