Adobe ColdFusion: Incorrect authorization allows arbitrary code execution
Summary
Adobe ColdFusion 2023 and 2025 contain an Incorrect Authorization flaw (CWE-863) that can lead to arbitrary code execution in the context of the current user. An attacker needs a local, low-privileged account on the server, and no user interaction is required. Because the scope is changed, a successful attack can reach beyond ColdFusion itself. Adobe reports no known exploits in the wild.
Affected
- Adobe ColdFusion 2025 up to and including 2025.0.13
- Adobe ColdFusion 2023 up to and including 2023.0.25
- Platform: All
Fixed in
- Adobe ColdFusion 2025: update to 2025.0.14 (Update 14)
- Adobe ColdFusion 2023: update to 2023.0.26 (Update 26)
Workaround
- No CVE-specific workaround is known. Updating is the only reliable mitigation.
- Adobe recommends updating the ColdFusion JDK/JRE to the latest LTS update release and using the latest MySQL Java connector.
- Update 26 requires the update-management role for admin and package-manager endpoints. Review role assignments after patching.
- Known issue: the outbound network policy covers only the top-level URL fetched by cfdocument, not sub-resource URLs in rendered HTML. Adobe advises against rendering untrusted HTML with external resource URLs until this is fixed.
Exploitation
- Adobe is not aware of any exploits in the wild for any issue in bulletin APSB26-144.
- CISA SSVC assessment: exploitation none, not automatable, total technical impact.
- No public proof-of-concept found. This does not rule out that one exists.
- KEV status: unverified.
Our recommendation
- Identify all ColdFusion 2023 and 2025 installations and their versions.
- Update to 2025.0.14 or 2023.0.26 as soon as possible. Treat the whole APSB26-144 bundle as one update, especially for internet-facing servers.
- Review local accounts on ColdFusion servers and remove unneeded ones, since this flaw requires a local low-privileged account.
- After patching, review role assignments for the update-management role and monitor for unexpected code execution or file changes.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Adobe Security Bulletin APSB26-144 www.adobe.com
- ColdFusion 2023 Release Update 26 (Adobe) guides.adobe.com
- Strix CVE-2026-105901 www.strix.ai
- Tenable plugin 366551 www.tenable.com
- Blacktree: Adobe October 2026 security fixes blacktree.nl
- Zero Day Initiative: October 2026 security update review www.zerodayinitiative.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 17:13.
Original description (NVD)
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation of this issue does not require user interaction. Scope is changed.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
