Ghost CMS: Stored cross-site scripting via oEmbed photo responses
Summary
Ghost, an open-source Node.js content management system, stores untrusted scripts when a post embeds a URL from an attacker-controlled website. The scripts can run in the Ghost editor, on the published site and in newsletter emails, and may lead to compromise of a staff user's admin session. The issue was fixed by rejecting photo-type oEmbed responses from non-allowlisted providers.
Affected
- Ghost from 2.1.0 up to and including 6.63.x (fixed in 6.64.0)
- Some sources state the range starts at 2.5.0; 2.1.0 is treated as the conservative start
- Related Ghost XSS issue CVE-2026-105643 lists versions up to 6.67.0 as affected
Fixed in
- Ghost 6.64.0 (vendor fix)
- Some third-party sources recommend 6.64.1 or later; not confirmed by the vendor
- Check the latest stable Ghost release, as newer XSS fixes exist
Workaround
- No vendor workaround. Upgrading is the fix.
- An unverified third-party source suggests disabling oEmbed functionality temporarily; test before relying on it.
Exploitation
- CISA SSVC: Exploitation none, not automatable
- No evidence of exploitation in the wild found; not confirmed in CISA KEV
- No confirmed public proof of concept
Our recommendation
- Update Ghost to the latest stable release, at least 6.64.0
- For self-hosted installations (Docker, Ghost-CLI, VM), apply the update promptly
- Review staff accounts and sessions for unusual activity and enforce strong authentication
- Check published posts and newsletters for unexpected embedded scripts
- Monitor vendor advisories for related Ghost XSS fixes
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- GitHub Security Advisory GHSA-v3xr-g6p2-fvgv github.com
- Ghost release v6.64.0 github.com
- Ghost fix commit d23d552 github.com
- Ghost pull request #30763 github.com
- GitLab Advisory Database: CVE-2026-105650 advisories.gitlab.com
- OSV: BIT-ghost-2026-105650 osv.dev
- OSV: GHSA-v3xr-g6p2-fvgv osv.dev
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 20:53.
Original description (NVD)
Ghost is a Node.js content management system. From 2.1.0 until 6.64.0, embedding a URL from an attacker-controlled website could result in untrusted scripts being stored in post content. These scripts could run in the Ghost editor, on the published site, and in newsletter emails, possibly resulting in compromise of a staff user's admin session. This issue is fixed in version 6.64.0.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
