IT SBIT Services
Schneeberger
DEEN
CVE tracker

Tuleap Enterprise Edition: Stored Cross-Site Scripting (XSS)

CVE-2026-105410High 8.7

← All vulnerabilities

Summary

Tuleap Enterprise Edition versions 17.0 through 17.5 contain a stored Cross-Site Scripting vulnerability. An attacker with a low-privileged logged-in account could store malicious script code that runs in the browser session of another user when that user interacts with crafted content. Successful exploitation can affect confidentiality and integrity of data in the victim's session.

Affected

  • Tuleap Enterprise Edition 17.0-1 to 17.0-41 (according to aggregators; build numbers to be confirmed with the vendor advisory)
  • Tuleap Enterprise Edition 17.5-1 to 17.5-32 (according to aggregators; build numbers to be confirmed with the vendor advisory)

Fixed in

  • Upgrade to Tuleap Enterprise Edition 17.6 or later (unverified, to be confirmed on the vendor advisory)
  • Or apply the vendor's security fix. Patch details: Unknown.

Workaround

  • Unknown. No vendor workaround found.

Exploitation

  • Known exploited: no. Not listed in KEV.
  • Public exploit: none found. VulDB states no exploit is available.
  • CISA SSVC: exploitation none, not automatable, total technical impact.

Our recommendation

  • Check whether Tuleap Enterprise Edition 17.0 or 17.5 is in use and verify the build number against the vendor advisory.
  • Apply the vendor's fix as soon as possible, prioritising internet-facing or widely shared instances.
  • Until patched, restrict account creation and logins, limit access to trusted networks, and review user-generated content.
  • Also check CVE-2026-111497 (Node.js issue) if you run version 17.5, and patch related advisories together.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 04:57.

Original description (NVD)

A Stored Cross-site Scripting (XSS) vulnerability affecting Tuleap Enterprise Edition from 17.0 through 17.5 could allow an attacker to execute arbitrary script code in user's browser session.

NVD references (1)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.