Gist RubyGem: Disabled TLS certificate verification
Summary
The gist RubyGem, a command-line client for uploading content to GitHub Gist, disables TLS certificate verification in its HTTPS connection code. An attacker positioned on the network path between the client and GitHub can present any certificate, intercept the traffic, and steal OAuth tokens or login credentials. With these, the attacker can read and modify the victim's gists. The attack requires an on-path position and does not affect the GitHub platform itself.
Affected
- gist RubyGem from 4.0.0 up to, but not including, 6.1.0
- Default configuration: unaffected according to the CNA record
- Vulnerable code: http_connection in lib/gist.rb sets VERIFY_NONE
Fixed in
- Upgrade to gist 6.1.0 or later
- The fix replaces the no-verification setting with peer verification (VERIFY_PEER)
Workaround
- Unknown. No vendor-approved workaround for the vulnerable versions was found.
Exploitation
- CISA SSVC assessment: exploitation none, not automatable, partial technical impact
- Not listed in the CISA KEV catalogue according to the sources found
- EPSS score about 0.2% (2026-10-06)
- Public proof-of-concept material may exist; sources conflict
- No confirmed exploitation in the wild found
Our recommendation
- Inventory systems with the gist gem, including Gemfile.lock entries, package-manager installs and CI jobs
- Upgrade to gist 6.1.0 or later in the next regular maintenance cycle
- Until upgraded, avoid using the gist client on untrusted networks such as public Wi-Fi
- If an on-path incident is suspected, rotate the GitHub tokens used by affected installations
Public exploits
Links to third-party sites, not checked by us – exploit code can contain malware. Only use it in isolated test environments.
- Proof of concept on GitHub (1 repositories)
abraxas/cve-2026-105221-gist-tls
Research sources
- CVE-2026-105221 OSV record osv.dev
- VulnCheck advisory: Gist RubyGem before 6.1.0 www.vulncheck.com
- Upstream fix commit github.com
- Upstream issue #373 github.com
- Vulnerable code at v6.0.0 github.com
- gist project repository github.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 07:33.
Original description (NVD)
The gist RubyGem before 6.1.0 contains an improper certificate validation vulnerability that allows on-path attackers to intercept HTTPS traffic because http_connection in lib/gist.rb sets VERIFY_NONE. Attackers can present any certificate to read or modify GitHub API traffic, stealing OAuth tokens and login credentials to read and modify the victim's gists.
NVD references (5)
- https://github.com/defunkt/gist
- https://github.com/defunkt/gist/blob/v6.0.0/lib/gist.rb#L466-L468
- https://github.com/defunkt/gist/commit/07ccc1a6d46e9d36f0e85d0b1c5d795890ae6bcf
- https://github.com/defunkt/gist/issues/373
- https://www.vulncheck.com/advisories/gist-rubygem-before-6.1.0-disabled-tls-certificate-verification
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
