Search Regex WordPress plugin: PHP object injection via deserialization
Summary
The Search Regex plugin for WordPress up to version 3.5 deserializes untrusted input in the replace_all function. An authenticated attacker with at least subscriber-level access can inject a PHP object. If a suitable POP chain is present on the target site, this can lead to code execution on the web server, with a CVSS score of 8.0.
Affected
- Search Regex WordPress plugin, versions 0 to 3.5 (inclusive)
Fixed in
- Version 3.5.1 (released 6 October 2026, according to the vendor changelog; the fix for this CVE is inferred from the changelog and not confirmed by the Wordfence advisory)
Workaround
- Unknown. No vendor workaround found for sites that cannot update.
- Interim measures (not from a vendor source): disable open user registration, remove unneeded subscriber accounts.
Exploitation
- No evidence of exploitation in the wild found.
- No public proof of concept found; this does not rule one out.
- CISA SSVC: exploitation none, automatable no, technical impact total.
Our recommendation
- Update the Search Regex plugin to version 3.5.1 or later promptly on every WordPress site that uses it.
- Check whether attackers could register or obtain subscriber accounts, and disable open registration if not needed.
- Review user meta for unexpected serialized values after updating.
- Monitor for unusual activity from subscriber accounts.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Wordfence threat intelligence record www.wordfence.com
- Plugin changeset 3.5.1 (CVE reference) plugins.trac.wordpress.org
- GitHub release 3.5.1 github.com
- GitHub pull request 265 github.com
- WordPress.org plugin page wordpress.org
- VulDB CVE entry vuldb.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 21:16.
Original description (NVD)
The Search Regex plugin for WordPress is vulnerable to PHP Object Injection in version 3.5 via deserialization of untrusted input in the replace_all function. This allows authenticated attackers, with subscriber-level access and above, to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
