Advanced Form Integration: Authentication bypass via unverified password change
Summary
The Advanced Form Integration plugin for WordPress, up to and including version 2.9.0, lets unauthenticated attackers change the password of any WordPress user, including administrators. The attack works through a public Contact Form 7 form when an administrator has configured an integration that maps form fields to the Ultimate Member Update Profile Field action. Successful exploitation can lead to full takeover of the website.
Affected
- Advanced Form Integration by nasirahmed, all versions up to and including 2.9.0
- Only sites where an administrator has configured a Contact Form 7 integration with the Ultimate Member Update Profile Field action
Fixed in
- Version 2.10.0 or later is expected to fix the issue (research sources only, not confirmed by the vendor)
- Vendor advisory or release note: Unknown.
Workaround
- Deactivate the plugin until a fixed version is installed.
- Remove or disable any Contact Form 7 integration that maps public form fields to the Ultimate Member Update Profile Field action.
Exploitation
- No known exploitation in the wild at the time of writing.
- No public proof-of-concept found in the research.
- EPSS 0.00408 (low).
- CISA SSVC: exploitation none, automatable no, technical impact total.
Our recommendation
- Check whether the plugin is installed and whether the version is 2.9.0 or earlier.
- Deactivate the plugin or remove the affected integrations until a fixed version is confirmed.
- Update to 2.10.0 or later when confirmed, and verify the installed version in the WordPress admin.
- Review administrator accounts for unexpected password changes or logins, and reset passwords if in doubt.
- Monitor for vendor information and for a CISA KEV listing.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- Wordfence threat intelligence record www.wordfence.com
- Changeset for tag 2.10.0 plugins.trac.wordpress.org
- Trigger code for Contact Form 7 (tag 2.9.0) plugins.trac.wordpress.org
- Ultimate Member action code (tag 2.9.0, line 169) plugins.trac.wordpress.org
- Ultimate Member action code (tag 2.9.0, line 83) plugins.trac.wordpress.org
- Third-party threat center entry www.ionix.io
- HOL Guard CVE entry hol.org
- Plugin directory browser plugins.trac.wordpress.org
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 20:21.
Original description (NVD)
The Advanced Form Integration — Connect Forms to 300+ Apps plugin for WordPress is vulnerable to Authentication Bypass via Unverified Password Change in all versions up to, and including, 2.9.0 The `adfoin_ultimatememberac_send_data` function, which powers the Ultimate Member "Update Profile Field" action, resolves the target WordPress user from an attacker-supplied email address and passes an attacker-controlled field key and value directly to `UM()->user()->update_profile()` in the `account` context — which explicitly bypasses Ultimate Member's banned-key validation — without performing any submitter identity verification, ownership check, capability check, current-password reauthentication, or restriction on sensitive keys such as `user_pass`. This makes it possible for unauthenticated attackers to change the password of any WordPress user account, including Administrator accounts, by submitting a public Contact Form 7 form with a target email and `user_pass` as the field key, enabling full site takeover. Exploitation requires an administrator to have pre-configured a Contact Form 7 integration that maps the target email, field key, and value from public form inputs to the Ultimate Member Update Profile Field action — the exact workflow the plugin's own UI advertises for this action type.
NVD references (6)
- https://plugins.trac.wordpress.org/browser/advanced-form-integration/
- https://plugins.trac.wordpress.org/browser/advanced-form-integration/tags/2.9.0/includes/triggers/cf7/cf7.php…
- https://plugins.trac.wordpress.org/browser/advanced-form-integration/tags/2.9.0/platforms/ultimatememberac/ul…
- https://plugins.trac.wordpress.org/browser/advanced-form-integration/tags/2.9.0/platforms/ultimatememberac/ul…
- https://plugins.trac.wordpress.org/changeset?reponame=&new=3725787%40advanced-form-integration%2Ftags%2F2.10.…
- https://www.wordfence.com/threat-intel/vulnerabilities/id/586fd95e-88c7-4eb8-826c-ae46a11ac21f?source=cve
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
