Loom for AWS: Missing authentication allows super-admin access
Summary
Loom for AWS, an open-source AI agent orchestration platform, does not enforce authentication in versions before 1.6.1 when no identity provider is configured. A remote attacker without credentials can send requests to the application API and obtain super-admin rights over the agent control plane. This allows registering tool servers, reading stored integration credentials and rewriting IAM role policies of managed agent roles, which can lead to compromise of the cloud account. The CVSS v4.0 base score is 10.0 (Critical).
Affected
- Loom for AWS versions before 1.6.1
- Relevant only for deployments where no identity provider is configured
Fixed in
- Version 1.6.1 (released 4 August 2026)
- Version 1.7.0 is recommended by AWS, as it also fixes CVE-2026-103957 and CVE-2026-103958
Workaround
- Configure an Amazon Cognito user pool or an active external identity provider before the backend is reachable beyond localhost
- Ensure LOOM_ALLOW_UNAUTHENTICATED_LOCAL_DEV is unset in any deployed (non-local-dev) environment
Exploitation
- A third-party proof-of-concept has been published; its content was not reviewed
- No confirmed exploitation in the wild found; not verified directly against the CISA KEV catalogue
- CISA SSVC: exploitation none, automatable yes, technical impact total
- A Nuclei detection template has been submitted to the ProjectDiscovery templates repository
Our recommendation
- Inventory all Loom deployments and check their versions; upgrade to 1.7.0
- Verify that an identity provider is configured and that the instance is not reachable from the internet
- If an instance was exposed without identity provider, review it for compromise: check integration credentials, IAM role policies and CloudTrail, and rotate affected secrets
- Use the Nuclei template to scan your own systems
Public exploits
Links to third-party sites, not checked by us – exploit code can contain malware. Only use it in isolated test environments.
- Proof of concept on GitHub (1 repositories)
abraxas/cve-2026-103956-loom-unauth
Research sources
- AWS Security Bulletin 2026-124-AWS aws.amazon.com
- GitHub Security Advisory GHSA-vgmj-998f-r8mp github.com
- Loom release v1.6.1 github.com
- Nuclei template pull request for CVE-2026-103956 github.com
- NVD-based analysis via CVE aggregator app.opencve.io
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 30 Oct 2026, 14:42.
Original description (NVD)
Missing authentication for critical function in the authentication dependency in Loom for AWS before 1.6.1 allowed remote actors to obtain super-admin authority over the agent control plane, including registering tool servers, reading stored integration credentials, and rewriting the IAM role policies attached to managed agent roles, via any request to the application API in a deployment where no identity provider is configured. To remediate this issue, users should upgrade to version 1.6.1 or later.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
