Ghost: Privilege escalation via notifications system
Summary
Ghost versions from 2.21.0 before 6.56.0 contain a privilege escalation flaw in the notifications system. A low-privilege staff user can gain higher staff roles without proper authorization checks. The attack requires a valid low-privilege staff account and user interaction, according to the CVSS 4.0 vector.
Affected
- Ghost from 2.21.0 before 6.56.0 (npm package ghost)
- Self-hosted and Docker-based installations of the affected versions
Fixed in
- Ghost 6.56.0 (vendor advisory lists 6.56.0 as the patched version; verification against the GHSA is recommended)
- Latest Ghost release recommended, as related staff-role fixes were released later (e.g. 6.60.0 for CVE-2026-105680)
Workaround
Unknown.
Exploitation
- CISA SSVC: Exploitation none, Automatable no, Technical Impact total
- Not listed in CISA KEV
- No public proof of concept known; no in-the-wild exploitation known
Our recommendation
- Inventory all Ghost instances, including Docker deployments, and their versions
- Upgrade to Ghost 6.56.0 at minimum, preferably to the latest release
- Review staff accounts and roles and remove unused low-privilege accounts
- Confirm the affected range and fix in the GHSA advisory GHSA-pv24-pfvg-vr83
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- GitHub Security Advisory GHSA-pv24-pfvg-vr83 github.com
- VulnCheck advisory www.vulncheck.com
- OSV record CVE-2026-103286 osv.dev
- GitHub Ghost release v6.56.0 github.com
- OpenCVE CVE-2026-103286 app.opencve.io
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 11:38.
Original description (NVD)
Ghost versions from 2.21.0 before 6.56.0 contain a privilege escalation vulnerability in the notifications system that allows low-privilege staff users to escalate to higher-privilege staff roles. Attackers with low-privilege staff access can exploit the notifications system to gain elevated privileges without proper authorization checks.
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
