IT SBIT Services
Schneeberger
DEEN
CVE tracker

Apache Tomcat: Authentication bypass in JNDIRealm with non-GSSAPI SASL

CVE-2026-101296Critical 9.1

← All vulnerabilities

Summary

Apache Tomcat's JNDIRealm, used for logins against directory services such as LDAP, can be bypassed when a non-GSSAPI SASL authentication mechanism is configured. An attacker can authenticate over the network without knowing the correct password and reach protected web applications and administrative resources. Exposure only applies to installations that use JNDIRealm with a non-GSSAPI SASL mechanism.

Affected

  • Apache Tomcat 11.0.0-M1 through 11.0.26
  • Apache Tomcat 10.1.0-M1 through 10.1.60
  • Apache Tomcat 9.0.0.M1 through 9.0.122
  • Apache Tomcat 8.5.0 through 8.5.100 (EOL, known to be affected)
  • Apache Tomcat 7.0.0 through 7.0.109 (EOL, known to be affected)
  • Other unsupported versions may also be affected.
  • Default configuration is unaffected.
  • Distribution and embedded Tomcat packages may differ; check your vendor's advisory.

Fixed in

  • Apache Tomcat 11.0.27
  • Apache Tomcat 10.1.61
  • Apache Tomcat 9.0.123
  • Apache does not provide fixes for 8.5 and 7.0; upgrade to a supported branch.

Workaround

  • Enforce Kerberos GSSAPI authentication in JNDIRealm and remove non-GSSAPI SASL mechanisms (vendor-related guidance from Red Hat, not verified against Apache).
  • Restrict network access to endpoints protected by the JNDIRealm until patched.
  • Enforce authentication at an identity-aware gateway in front of the realm.

Exploitation

  • No evidence of active exploitation known at the time of research.
  • Not listed as known exploited in CISA KEV according to one feed; KEV not directly verified.
  • No public proof-of-concept found in the searches performed; this does not prove none exists.
  • CISA SSVC: exploitation none, automatable no, technical impact total.

Our recommendation

  • Upgrade Tomcat to 11.0.27, 10.1.61 or 9.0.123 without delay.
  • Replace Tomcat 8.5 and 7.0 installations with a supported branch.
  • Check all JNDIRealm configurations for non-GSSAPI SASL use and prioritise internet-facing applications.
  • Review authentication logs for unexpected successful logins during the exposure window.
  • Verify the Tomcat version in embedded or bundled deployments and in distribution packages.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 06:18.

Original description (NVD)

A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

NVD references (2)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.