IT SBIT Services
Schneeberger
DEEN
CVE tracker

Aspose Importer & Exporter WordPress plugin: Path Traversal in file download

CVE-2015-20124High 8.7

← All vulnerabilities

Summary

The Aspose Importer & Exporter plugin for WordPress before version 3.0 contains a Path Traversal vulnerability in the aspose_import_export_download.php endpoint. An unauthenticated remote attacker can send crafted GET requests with traversal sequences in the 'file' parameter to download arbitrary files from the server. A demonstrated target is wp-config.php, which contains database credentials and can lead to full compromise of the WordPress site.

Affected

  • Aspose Importer & Exporter WordPress plugin, versions 1.0 to before 3.0
  • Unknown whether the plugin is still maintained; a Patchstack entry lists a discontinued plugin version 2.0 or lower

Fixed in

  • Version 3.0 (according to OpenCVE and VulDB)
  • Availability of version 3.0 on wordpress.org has not been verified

Workaround

  • Unknown. No vendor-published workaround found.
  • If the plugin cannot be updated to 3.0, remove it.

Exploitation

  • Public proof-of-concept code: a ProjectDiscovery Nuclei template exists and Packet Storm lists an exploit entry.
  • VulnCheck lists the vulnerability as exploited (Observed) in its KEV catalog.
  • CISA KEV status is unconfirmed.
  • The CISA SSVC assessment lists exploitation as PoC and the flaw as automatable.
  • Shadowserver first-observation date (2023-10-20) conflicts with the publication date (2026-10-20) and is unverified.
  • EPSS is low (0.00389).

Our recommendation

  • Identify all WordPress sites with the Aspose Importer & Exporter plugin and check the installed version.
  • Update to version 3.0 or later if available; otherwise remove the plugin.
  • Prioritise internet-facing sites because no login is required.
  • If the plugin was exposed, rotate database credentials and review web server logs for requests to aspose_import_export_download.php with traversal sequences.
  • Verify the NVD status and the release history on wordpress.org.

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 01:24.

Original description (NVD)

Aspose Importer & Exporter plugin for WordPress before 3.0 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the unsanitized 'file' parameter. Attackers can send GET requests to aspose_import_export_download.php with traversal sequences like ../../../wp-config.php to read database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-20.

NVD references (4)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.