IT SBIT Services
Schneeberger
DEEN
CVE tracker

TinyMCE Thumbnail Gallery WordPress plugin: Path traversal via download-image.php

CVE-2012-20002High 8.7

← All vulnerabilities

Summary

The TinyMCE Thumbnail Gallery plugin for WordPress before version 1.1.0 contains a path traversal flaw in download-image.php. An unauthenticated attacker can send a GET request with traversal sequences in the href parameter to read arbitrary files on the web server. Files such as wp-config.php, which contains database credentials, can be retrieved if the plugin is installed and the file is reachable.

Affected

  • TinyMCE Thumbnail Gallery plugin for WordPress, versions 0.10 to before 1.1.0 (according to the CVE record)
  • Wordfence lists versions up to and including 1.0.7 as affected
  • The lower bound could not be confirmed from a primary source

Fixed in

  • Version 1.1.0 (WPScan, WordPress.org changeset 556394)

Workaround

Unknown.

  • Restrict direct web access to php/download-image.php at the web server or WAF level, as a general hardening step if patching is delayed

Exploitation

  • Public proof of concept: Exploit-DB 19022 (dated 2012-06-08)
  • A Nuclei detection template exists
  • The CVE text states exploitation was first observed by Shadowserver on 2023-10-19; this could not be verified
  • KEV status conflicts between sources; verify in the CISA KEV catalogue
  • CISA SSVC: exploitation status poc, automatable: yes

Our recommendation

  • Inventory WordPress sites for this plugin and its version; any version below 1.1.0 is affected
  • Update to version 1.1.0 or later, or remove the plugin if it is unused
  • Review web server logs for requests to download-image.php; treat hits as possible credential exposure
  • Rotate database credentials and salts in wp-config.php if such requests are found
  • Check whether the plugin is still maintained before reuse

Public exploits

PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 1 Nov 2026, 01:27.

Original description (NVD)

TinyMCE Thumbnail Gallery plugin for WordPress before 1.1.0 contains a path traversal vulnerability that allows unauthenticated attackers to read arbitrary files via the href parameter. Attackers can send GET requests to /php/download-image.php with traversal sequences like ../../../../wp-config.php to retrieve database credentials and system files. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.

NVD references (6)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.