IT SBIT Services
Schneeberger
DEEN
CVE tracker

Google Brotli: Out-of-bounds write in decoder allows remote code execution

CVE-2026-111497Critical 9.2Actively exploitedPublic exploit

← All vulnerabilities

Actively exploited – in the CISA catalogue of Known Exploited Vulnerabilities since 27 Oct 2026
Deadline for US federal agencies: 10 Nov 2026

Summary

A buffer overflow in the Brotli decompression library from Google, which many applications and runtimes use, can be triggered by a crafted Brotli-compressed data stream. An unauthenticated remote attacker can corrupt decoder memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code. Exploitation in the wild is confirmed, and CISA has added the flaw to its Known Exploited Vulnerabilities catalog. The CVSS v4.0 base score is 9.2 (critical).

Affected

  • Google Brotli 1.0.3 to before 1.0.10
  • Google Brotli 1.1.0 to before 1.1.1
  • Google Brotli 1.2.0 to before 1.2.1
  • Products that embed or bundle a vulnerable Brotli decoder, for example Node.js 20.x and earlier releases of other runtimes

Fixed in

  • Google Brotli 1.0.10, 1.1.1 or 1.2.1 (or later)
  • Node.js 22.23.4, 24.22.1 and 26.12.1 (security release of October 21, 2026)
  • Other embedding products: check the respective vendor advisory

Workaround

No workaround documented. Apply the update.

Exploitation

  • CISA Known Exploited Vulnerabilities catalog: added 2026-10-27
  • CISA SSVC: exploitation active, not automatable, technical impact total
  • Attack requires only a crafted compressed stream, no authentication

Our recommendation

  • Identify all systems and applications that use Brotli, including copies bundled in runtimes, containers and packages.
  • Update Google Brotli to 1.0.10, 1.1.1 or 1.2.1 and install vendor updates for embedded products.
  • Replace Node.js 20.x, which receives no fix because it is end of life, with a supported release line.
  • Prioritize internet-facing services that decode Content-Encoding: br.
  • Monitor these services for crashes or unexpected behaviour.

Public exploits

Links to third-party sites, not checked by us – exploit code can contain malware. Only use it in isolated test environments.

Research sources

Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 30 Oct 2026, 13:32.

Original description (NVD)

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Required action (CISA)

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

NVD references (21)

Sources

The tracker combines official, freely usable data sources – updated continuously:

This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.

Affected? We can help.

We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.