IBM Langflow OSS: Remote code execution via OS command injection
Summary
IBM Langflow OSS versions 1.0.0 through 1.12.3 do not properly neutralize special elements used in an OS command. A remote attacker with a valid, low-privileged account can execute arbitrary code on the server without user interaction, which may expose stored credentials such as API keys. Langflow listens on localhost by default, so the risk depends on how it is deployed and who can reach it.
Affected
- IBM Langflow OSS 1.0.0 through 1.12.3
Fixed in
- Upgrade to 1.12.4 as recommended in the official CVE record. The IBM bulletin 7293015 was not verified directly.
- A separate IBM bulletin (7294467) covers up to 1.12.8 and is fixed in 1.13.0. Upgrading to 1.13.0 is the safer target.
Workaround
Unknown.
Exploitation
- CISA SSVC: exploitation none, not automatable.
- No known exploitation in the wild; not listed in KEV.
- No public exploit reported.
- EPSS: 0.69 % (percentile 53).
Our recommendation
- Inventory all Langflow instances and versions, including containers and cloud VMs.
- Upgrade to 1.13.0, or at least to 1.12.4 after confirming the IBM bulletin.
- Until patched, restrict access to trusted networks and remove unneeded accounts.
- If an instance was internet-exposed while vulnerable, rotate API keys and credentials stored in Langflow.
- Prioritise shared, internet-reachable or multi-user instances.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- IBM Security Bulletin 7293015 www.ibm.com
- Strix: CVE-2026-104328 www.strix.ai
- Threat Intelligence: CVE-2026-104328 cve.threatint.com
- VulDB 428578 vuldb.com
- Langflow GitHub Security Advisory GHSA-w794-rj3p-xv45 github.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 09:16.
Original description (NVD)
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special elements used in an OS command.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
