Langflow OSS: Code injection leads to remote code execution
Summary
IBM Langflow OSS versions 1.0.0 through 1.12.3 contain a code injection flaw (CWE-94) caused by improper neutralization of special elements. A remote attacker with a valid low-privilege account can execute arbitrary code on the server, with high impact to confidentiality, integrity and availability (CVSS 8.8). The exact vulnerable component and trigger are not publicly described.
Affected
- IBM Langflow OSS 1.0.0 through 1.12.3
Fixed in
- Upgrade to Langflow OSS 1.12.4 (minimum fix per the IBM CVE record)
- A later IBM bulletin (7294467) references 1.13.0 as the target release; verify against the IBM bulletin before rollout
Workaround
- No official workaround is confirmed for this CVE.
- General hardening until patched: keep Langflow off the public internet, disable auto-login, and restrict who can create or edit flows.
Exploitation
- No evidence of exploitation or public proof of concept for this CVE was found.
- CISA SSVC assessment: exploitation none, not automatable, total technical impact.
- Other Langflow vulnerabilities are being actively exploited; this does not apply to CVE-2026-101288 by itself.
Our recommendation
- Inventory all Langflow OSS instances, including Docker and pip installations.
- Upgrade to at least 1.12.4, preferably the latest release, after checking the IBM bulletin and testing flows.
- Disable auto-login and keep the service off the public internet.
- Restrict flow creation and editing to trusted users and review accounts with access.
- After patching, rotate API keys and credentials stored in the platform.
- Review logs for unusual activity.
Public exploits
PoC-in-GitHub, Metasploit and Exploit-DB list nothing for this CVE.
Research sources
- IBM Security Bulletin 7293015 www.ibm.com
- Strix CVE-2026-101288 www.strix.ai
- CVE record mirror (threatint) CVE-2026-101288 cve.threatint.com
- GBHackers: IBM patches multiple Langflow OSS flaws gbhackers.com
- HOL Guard: Langflow batch upgrade campaign hol.org
- Cybersecurity News: Langflow RCE exploited cybersecuritynews.com
Researched and written up in English and German by an AI (Claude by Anthropic) based on NVD, CISA, EPSS and the sources listed. The vendor information is authoritative. Researched on 31 Oct 2026, 09:17.
Original description (NVD)
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special elements used in code.
NVD references (1)
Sources
The tracker combines official, freely usable data sources – updated continuously:
- NVD (NIST) – CVEs, rating (CVSS), affected products
- CISA KEV – vulnerabilities confirmed by CISA as actively exploited
- CISA Vulnrichment – CISA assessment (SSVC) in the official CVE record
- FIRST EPSS – probability of exploitation
- Microsoft MSRC – Patch Tuesday: vulnerabilities, severity, updates
- PoC-in-GitHub – public proof-of-concept repositories
- Metasploit (Rapid7) – modules of the Metasploit Framework
- Exploit-DB (OffSec) – archive of public exploits (links only)
- Patch days: official vendor pages (linked per vendor) (Vendor patch days)
This product uses data from the NVD API but is not endorsed or certified by the NVD. EPSS data © FIRST.org.
Affected? We can help.
We check whether your systems are affected, install updates and close the gap – continuously with the System Health Checker if you wish.
